NineChime forum

Furry stuff, oekaki stuff, and other stuff.

You are not logged in.

#1 06-02-2011 04:53:05

New member

Problem Shipainter (Animation)

Hi friend,

I saw that you're on the shipainter animation Problem. I gave my members a quizz to know what are their configs. When I update Java on update21 all shipainter is frozen. However, some people can draw with update 25.

That doesn't depend on : OS, java version, browser, provider Internet. I wonder if that may be the server....
so I checked the old version 1.4.1 of my board oekaki. and I was surprised : all animations are Okay on 1.4.1... Since I update my board to 1.5.6, almost everybody has this problem. The animation is broken in the middle though.

here you can check by yourself :here the new  => the newest board
and here the old one :here the old

Thanks for reading and all work you did and you are still doing for improving Wacintaki <3

Best Regards,



#2 06-02-2011 06:30:54


Re: Problem Shipainter (Animation)

Unfortunately, this problem has existed well before 1.4.1, and some other Java developers are also (yet rarely) encountering this issue.  The only way I can find out more about what's going on is to set up a test case, but I haven't had the time to do that.

The problem is that when animations are being saved, they are split into chunks of exactly 65,000 bytes, and then compressed in order.  For some reason, on occasion, one of these chunks gets corrupted when being compressed.  Once an animation has been broken during compression, I don't believe there is any way to fix it.

There are basically three changes that were made to the draw code since 1.4.1.  The first is that usernames have been replaced with userIDs in the submission header, and the second is that if a Windows-style newline is discovered in the submission, the oekaki will assume the server is being stupid and will replace it with a UNIX-style newline.  I don't see how those changes would cause an issue.  The third change is a new Java parameter to turn off both DirectDraw and Direct3D support, which have been known to cause issues.  If you want, you can open up "shiBBS.php" into a text editor, and delete the following lines:


<!-- Disable Java DirectX support -->
<param name="java_arguments" value="-Dsun.java2d.noddraw=true -Dsun.java2d.d3d=false" />

I don't see how that will help, since display updates are not related to the animation compression routine.


#3 06-03-2011 16:21:44

New member

Re: Problem Shipainter (Animation)

Thank you for your reply.

I don't see how these changes can affect the new board too. I don't question your updates, really! but I can't wonder how the new board can do that more than 1.4.1

Anyway, thank very much for you advice I'll try this thing (even if I don't hope that will solve the problem)


Board footer

Yep, still running PunBB
© Copyright 2002–2008 PunBB